Beantwoord

Roam verliest connectie

  • 14 August 2023
  • 13 reacties
  • 403 Bekeken

Goede dag,
 

Mijn Sonos Roam heeft sinds dat ik hem heb een probleem. Deze verliest op willekeurige tijdstippen de connectie met mijn netwerk. Op het moment dat het gebeurt is de Roam niet meer zichtbaar in de app en de Google Assistent geeft op dat moment aan dat hij niet verbonden is met het internet (op de Roam zelf). Ik heb ook een Sonos One SL en deze heeft dit probleem niet. 

Ik heb de Roam reeds meermaals gereset en opnieuw toegevoegd aan mijn netwerk. Hij heeft een fixed IP gestuurd vanuit de router. Ik heb een mesh Wifi netwerk draaien op een TP-link M4 gebaseerd systeem. Het netwerk bestaat uit een 2,4 Ghz en 5 Ghz netwerk met hetzelfde SSID. Ik kan hierbij niet aangeven op welk kanaal het netwerk moet werken. De Roam staat op de originele draadloze lader. 

Geen van mijn andere (20+) apparaten op het netwerk hebben dit probleem. Ik kan me niet voorstellen dat dit zo hoort? Zie ik iets over het hoofd?

icon

Beste antwoord door Dari W 2 October 2023, 14:42

Bekijk origineel

Reageren op dit topic is niet mogelijk.

13 Reacties

Nog vergeten te vermelden. Op het moment dat de Roam de connectie heeft verloren zijn er 2 opties om hem weer tot leven te wekken:

  1. Ik doe niets. Misschien dat de Roam dan na verloop van tijd tot leven komt. 
  2. Ik zet de Roam volledig uit door de aan/uit knop 10 seconden ingedrukt te houden. Daarna weer aanzetten en de Roam is dan weer even gefixt. 

De tijd tussen functioneren en verliezen van connectie kan variëren van minuten tot dagen en lijkt volledig willekeurig. 

Hier zelfde probleem

Ook hetzelfde probleem hier. Sonos helpdesk vertelde mij dat het komt omdat ik een mesh netwerk heb, net als jij. De roam kan niet overschakelen naar een ander wifi access point en verliest dan de verbinding. Na 2 jaar is er nog steeds geen oplossing behalve de Sonos Roam helemaal aan en uitzetten.

Mijn overige Sonos producten hebben dit probleem niet omdat die met hetzelfde acces point verbonden blijven.

@Baldert, ik verwacht dat het ook ergens in die hoek zit. Heb na veelvuldig contact met Sonos en vele aanpassingen aan de plaatsing van de Roam, netwerk instellingen en Sonos instellingen te horen gekregen dat er toch iets mis was met de batterij van de Roam. Heb nu een paar dagen een nieuw exemplaar. Ik hoop  deze niet het probleem gaat vertonen, maar ik zal jullie hier op de hoogte houden. 

@Sarge_Loco ik ben benieuwd of dat iets oplost. 

@Baldert ik heb inderdaad met Unifi, lijkt het zelfde probleem, maar hem 3 keer per dag aan en uitzetten is geen doen. Maar Sonos zegt geen oplossing te hebben. 

Sonos zegt dat het in een toekomstige firmware update wordt opgelost. Maar dat zeggen ze al 2 jaar..

 

Ik heb "mesh technology" (volgens mij is dat 802.11r) uitgezet voor de roams. Ik laat wel weten of dat helpt.

Reputatie 3
Badge +2

Beste forumleden,

Het probleem dat jullie beschreven klinkt wel degelijk als een issue met een mesh systeem. Wat er namelijk gebeurd bij een mesh systeem is dat ieder wifi punt vaak een DHCP server actief heeft. Een DHCP server zorgt ervoor dat het apparaat IP adressen (netwerktoegang) kan uitdelen aan andere apparaten die verbinding willen zoeken op het netwerk. An sich is dat helemaal prima. Echter is het zo dat Sonos iedere DHCP server als een apart netwerk ziet. Daarom kan het voorkomen dat je speakers gaat missen uit je app overzicht terwijl je wel op de juiste wifi zit. 

Simpel gezegd houdt dit in dat wanneer je telefoon verbinding maakt met punt A in het netwerk en Sonos met punt B deze elkaar niet zullen zien. Dit is dus op te lossen door de DHCP server op de access points uit te zetten en alleen via de router te laten draaien.

Beste forumleden,

Het probleem dat jullie beschreven klinkt wel degelijk als een issue met een mesh systeem. Wat er namelijk gebeurd bij een mesh systeem is dat ieder wifi punt vaak een DHCP server actief heeft. Een DHCP server zorgt ervoor dat het apparaat IP adressen (netwerktoegang) kan uitdelen aan andere apparaten die verbinding willen zoeken op het netwerk. An sich is dat helemaal prima. Echter is het zo dat Sonos iedere DHCP server als een apart netwerk ziet. Daarom kan het voorkomen dat je speakers gaat missen uit je app overzicht terwijl je wel op de juiste wifi zit. 

Simpel gezegd houdt dit in dat wanneer je telefoon verbinding maakt met punt A in het netwerk en Sonos met punt B deze elkaar niet zullen zien. Dit is dus op te lossen door de DHCP server op de access points uit te zetten en alleen via de router te laten draaien.

Stel dat dit klopt. Dan zou in dit verhaal de Sonos Roam niet zichtbaar zijn in de app, maar wel nog steeds een connectie hebben met het internet? Te testen door bijvoorbeeld de Google Assistant rechtsreeks op de Sonos aan te spreken (zonder een telefoon of een andere Sonos speaker te gebruiken). 

Reputatie 3
Badge +2

@Sarge_Loco 

In theorie klopt dat inderdaad hij blijft dan gewoon connectie houden met internet. En zou het dus gewoon moeten werken met Google Assistant. Mocht dit niet het geval zijn is het slim om toch eventjes contact op te nemen met onze technische support want dan is er waarschijnlijk iets anders aan de hand. Dan kunnen wij aan de hand van een systeemdiagnose uitlezen wat er gaande is met je roam en naar een oplossing toe werken.

Even een update vanuit mijn kant: als ik mesh technology uitzet voor de roam dan is het signaal op zolder te slecht voor de roam omdat deze niet overschakelt naar een ander access punt (ik heb niet voor niet een mesh netwerk). Dus dat is helaas ook geen oplossing.

@Sarge_Loco

In theorie klopt dat inderdaad hij blijft dan gewoon connectie houden met internet. En zou het dus gewoon moeten werken met Google Assistant. Mocht dit niet het geval zijn is het slim om toch eventjes contact op te nemen met onze technische support want dan is er waarschijnlijk iets anders aan de hand. Dan kunnen wij aan de hand van een systeemdiagnose uitlezen wat er gaande is met je roam en naar een oplossing toe werken.

Dankjewel voor de reactie. In mijn specifiek geval verloor de Roam daadwerkelijk connectie met het internet. Er bleek iets mis te zijn met de batterij van de Roam. Ik heb nu een ander exemplaar en alles draait voorlopig goed. Enkele punten die ik heb aangepast om de Roam vanuit zijn mijn eerste poging beter te laten functioneren:

  1. Plaatsing (niet te kort bij een koelkast of magnetron)
  2. Mesh uitgezet voor de roam via de TP-link instellingen
  3. Vast IP adres toegekend aan de Roam via de TP-link instellingen
  4. Batterij besparende instellingen uitgezet op de Roam, via de Sonos app
  5. Zorgen dat de Roam contact kan zoeken met Sonos en niet wordt geblokkeerd in de DNS (ik het een Adguard DNS blok er tussen zitten)

Ik maak nog steeds gebruik van een TP-Link Deco M4 mesh WiFi set waarbij mijn 2.4 Ghz en 5 Ghz WiFi dezelfde SSID hebben en dit lijkt voorlopig goed te gaan. Ik zal nog proberen wat er gebeurd als ik met de Roam rondom het huis loop waarbij hij normaal contact zou zoeken met de andere access points binnen het mesh systeem. 

@Sarge_Loco

In theorie klopt dat inderdaad hij blijft dan gewoon connectie houden met internet. En zou het dus gewoon moeten werken met Google Assistant. Mocht dit niet het geval zijn is het slim om toch eventjes contact op te nemen met onze technische support want dan is er waarschijnlijk iets anders aan de hand. Dan kunnen wij aan de hand van een systeemdiagnose uitlezen wat er gaande is met je roam en naar een oplossing toe werken.

Dankjewel voor de reactie. In mijn specifiek geval verloor de Roam daadwerkelijk connectie met het internet. Er bleek iets mis te zijn met de batterij van de Roam. Ik heb nu een ander exemplaar en alles draait voorlopig goed. Enkele punten die ik heb aangepast om de Roam vanuit zijn mijn eerste poging beter te laten functioneren:

  1. Plaatsing (niet te kort bij een koelkast of magnetron)
  2. Mesh uitgezet voor de roam via de TP-link instellingen
  3. Vast IP adres toegekend aan de Roam via de TP-link instellingen
  4. Batterij besparende instellingen uitgezet op de Roam, via de Sonos app
  5. Zorgen dat de Roam contact kan zoeken met Sonos en niet wordt geblokkeerd in de DNS (ik het een Adguard DNS blok er tussen zitten)

Ik maak nog steeds gebruik van een TP-Link Deco M4 mesh WiFi set waarbij mijn 2.4 Ghz en 5 Ghz WiFi dezelfde SSID hebben en dit lijkt voorlopig goed te gaan. Ik zal nog proberen wat er gebeurd als ik met de Roam rondom het huis loop waarbij hij normaal contact zou zoeken met de andere access points binnen het mesh systeem. 

Inmiddels heb ik dit getest en de Roam schakelt netjes tussen de verschillende mesh nodes als ik rondom het huis loop. Dit heb ik bevestigd via de TP-link interface. 

Ik heb dezelfde issues met 1 van de 3 Sonos Roams die we hebben. Gebruik TP-Link Deco Mesh en heb uiteindelijk een andere oorzaak gevonden. Wat ik wel eens heb begrepen is dat Sonos apparatuur erg slecht om kan gaan met kanaal wisselingen van je WiFi netwerk. Een techniek die wat mij betreft gebruikelijk is en waar Sonos erg moeilijk over doet en niet andersom.

Als ik mijn WiFi netwerk op zowel 2.4 GHz als 5 GHz heb ingesteld dan heeft deze ene Roam elke dag problemen. De enige oplossing is dan zoals @Sarge_Loco schreef: 

Ik zet de Roam volledig uit door de aan/uit knop 10 seconden ingedrukt te houden. Daarna weer aanzetten en de Roam is dan weer even gefixt.

Stel ik mijn WiFi netwerk daarentegen in op alleen 2.4 GHz dan blijft de Roam keurig werken (nu al 2 weken zonder problemen).

@Dari W : Sonos moet hier gewoon wat aan doen en ik wil met alle liefde als ICT-er helpen met het oplossen van dit probleem. Het is namelijk in de huidige tijd met de vele WiFi netwerken in en rond je huis niet meer te doen om geen Mesh technologie toe te passen. Tevens zijn automatische kanaalwisselingen ook al jaren aan de orde van de dag. Dit alles om de ontvangst optimaal te houden.