Beantwoord

Sonos Roam niet zichtbaar in App

  • 14 May 2021
  • 28 reacties
  • 602 Bekeken

Badge

Hoi Allemaal,

Sinds enkele weken een Sonos Roam. Ik ben op zich tevreden met het speakertje, maar heb een probleem dat de Roam niet altijd zichtbaar is in de app.

Vanochtend was de Roam zichtbaar in Systeem. Ik speel dus muziek af, maar op een gegeven moment is de Roam verdwenen uit Systeem (terwijl ik niets heb gedaan en de muziek gewoon doorspeelt). De muziek kan ik dus niet stoppen en dergelijke.

Zet ik vervolgend de Roam in standby, dan verschijnt Sonos Roam offline in mijn Systeem, zet ik de Roam vervolgens aan dan verdwijnt de Roam uit Systeem en is hij niet meer zichtbaar.

Als ik de Roam helemaal uitzet en dan weer aan en dan zie ik de Roam weer, maar ja dat is niet de bedoeling lijkt me. 

Heeft iemand hetzelfde probleem gehad en een oplossing hiervoor gevonden? 

icon

Beste antwoord door Eddie the Eagle 18 May 2021, 15:43

Bekijk origineel

Reageren op dit topic is niet mogelijk.

28 Reacties

Reputatie 1
Badge +1

Hey @Dovski goedemorgen.

 

Om wat beter beeld te krijgen van de situatie waarom de Roam af en toe offline staat, zou ik graag willen weten hoe thuis je netwerk er uit ziet.

Maak je alleen gebruik van de router die je gekregen hebt van de internet service provider, of heb je thuis nog andere WiFi punten liggen?

Badge

Hi Jeroen,

Mijn thuis netwerk ziet er als volgt uit:

  • Ziggo Connect box in bridge modus gelinkt aan
  • Security Gateway router/firewall van Unify die weer gelinkt is aan
  • Unify Switch waaraan gekoppeld zijn:
    • Access Points van Unify (AC-Pro's), hal, woonkamer, veranda
    • Sonos Boost 

Ik heb dus een eigen router en WiFi netwerk. Ik zie dat al mijn andere Sonos Producten (Soundbar, Subwoofer etc.) via de Sonos Boost aangestuurd worden. De Roam zoekt direct verbinding met een Access Point  zie ik (wordt dus niet door Boost aangestuurd). 

 

Reputatie 6
Badge +3

Ik heb geen directe oplossing maar ik vermoed dat je probleem er mee te maken heeft dat de Roam dus aan het ‘Roamen’ is tussen je verschillende AP`s. De Sonos Roam verdwijnt dus op het moment dat deze wisselt tussen je UAP`s bijvoorbeeld na een verplaatsing. Zoals je zelf al aangeeft, gebruikt de Sonos Roam geen SonosNet maar Wifi hetgeen een bewuste keuze is van Sonos vanwege de flexibele inzet.

Eigenlijk zou de Sonos Roam vanzelf weer moet opkomen, maar dat zal wellicht even duren. Er zijn instellingen in Unifi Controller die het wisselgedrag (roaming) tussen je AP`s kunnen beinvloeden en dus verbeteren maar daar heb ik geen ervaring mee omdat ik daar geen issues mee heb; ik heb ook geen Sonos Roam. Je zou eens een vraag kunnen plaatsen in het https://unifi-forum.nl/, dat is een actief forum waar gebruikers zijn die daar meer kennis en ervaring mee hebben.

Badge

Hoi Eddie,

Thx. voor je antwoord. Op het moment dat ik mijn omgeving aan het typen was en ik zag dat de Roam zelf verbinding maakt met een AP dacht ik ook dat dat wel eens het probleem zou kunnen zijn. Ik zal eens op het unifi forum iets plaatsen. 

Reputatie 6
Badge +3

Ja er zijn allerlei instellingen die dit gedrag beinvloeden. In theorie zou je zelfs een nieuw WLAN kunnen maken, SONOSWLAN, dat je slechts door 1 UAP laat uitzenden en daar je Sonos Roam mee verbinden, dan is er geen roaming meer. Aangezien je AP-AC-Pro`s hebt, moet je daar een heel eind mee komen.

Reputatie 1
Badge +1

Hey @Dovski 

 

Laten we ons dan inderdaad even focussen op de Access Points van Unify (AC-Pro's), hal, woonkamer, veranda

Zou je de volgende instellingen willen bekijken:

  • Draadloze netwerken → Geavanceerde opties → Block LAN to WLAN multicast and broadcast data (Deze optie moet uit staan)
  • Draadloze netwerken → Multicast enhancement → Enalble multicast enhancement (IGMPv3) (Deze optie moet ook uit staan)

Graag verneem ik of dit de gewenste oplossing is.

 

Badge

Multicast enhancement staat uit, Block LAN to WLAN multicast moet ik even zoeken waar ik dit kan vinden. 

 

Reputatie 6
Badge +3

Volgens mij is block LAN->WAN multicast nu verborgen als je de Auto-Optimize Network hebt aanstaan (zoals ik heb). Die zul je dus eerst moeten uitzetten. Ik heb de classic controller interface btw.

 

 

Reputatie 1
Badge +1

Volgens mij is block LAN->WAN multicast nu verborgen als je de Auto-Optimize Network hebt aanstaan (zoals ik heb). Die zul je dus eerst moeten uitzetten. Ik heb de classic controller interface btw.

 

 

Staat mij inderdaad wel iets bij dat er laatst een interface update is geweest.

Badge

Ik heb interface teruggezet naar de klassieke interface (kon hem niet vinden in de nieuwe User Interface)en Auto-Optimize Network uitgezet. Zal strx. gaan testen. 

Reputatie 6
Badge +3

Ik heb interface teruggezet naar de klassieke interface (kon hem niet vinden in de nieuwe User Interface)en Auto-Optimize Network uitgezet. Zal strx. gaan testen. 

Ja ik dacht al dat dat nodig zou zijn.

Badge

Goedemorgen, ik heb eens even getest. 

Ik zag zojuist de Roam (die ik helemaal had uitgezet) niet in mijn Sonos systeem staan en heb hem aangezet. Hij verscheen niet in mijn systeem, maar ik heb de Roam op Bluetooth verbinding gezet en nu is hij te zien in mijn Systeem. Zet ik de Roam uit, dan staat de Roam Offline in Systeem. Zet ik hem aan (op Wifi) dan verdwijnt de Roam uit mijn app. Door te switchen naar Bluetooth zie ik hem weer. 

Kijk ik in mijn netwerk dan zie ik dat de Roam wel is verbonden met een Access Point, maar met geen mogelijkheid komt hij via WiFi in mijn Sonos App bij Systeem te staan. 

Reputatie 6
Badge +3

Mbt Bluetooth, ik neem aan dat je dan kijkt in de app van je telefoon waarmee de Roam verbonden is ? Dan snap ik wel dat ie zichtbaar is.

Heb je al iets met de instelling “Block LAN to WLAN multicast” gedaan ? Op zich is het wel logisch dat die uit moet staan in jouw specifieke geval, dus LAN->WLAN multicast mag in jouw geval niet geblokkeerd worden.

 

 

 

Badge

Block LAN to WLAN Multicast staat geen vinkje bij, dat is goed? Of moet ik aanvinken? 

 

Reputatie 6
Badge +3

Block LAN to WLAN Multicast staat geen vinkje bij, dat is goed? Of moet ik aanvinken? 

 

Staat goed (dus geen vinkje).

Badge

ik zal het later nog even goed id gaten houden. Ik heb de Roam rond 08:15 uur aangezet (WiFi modus), toen niks te zien in de app op telefoon. Keek net weer even (rond 10:00 uur) en toen stond de Roam er ineens wel in…. volgende x eens even timen hoe lang het duurt voordat hij zichtbaar wordt in de app….

Reputatie 6
Badge +3

Ja, die zichtbaarheid in de App heeft volgens mij ook niks te maken met die multicast setting; dat is meer voor het spelen zelf . Om je netwerk niet te zwaar te belasten wordt door Sonos multicast gebruikt en aangezien jij 1 apparaat op WLAN hebt, moeten daar ook multicast gegevens naar toe zodat de Roam kan aanhaken. Dit kun je later nog optimaliseren door IGMP snooping aan te zetten in Unifi.

Ik heb alles op SonosNet, daar speelt dit niet, regelt Sonos zelf.

Hebben we het nog niet opgelost natuurlijk:

  • Dat roamen tussen AP`s zou nog steeds een probleem kunnen zijn.
  • Sonos Roam niet op guest netwerk neem ik aan ?
  • Vlan in gebruik ?
  • Firewall regels ?
  • Ik vraag me af of er niet toch een probleem met Spanning Tree Protocol zou kunnen zijn; normaliter speelt dit probleem alleen met bekabelde Sonos op managed switches maar omdat jij mixed mode hebt (wifi & SonosNet), vraag ik me nu af of dat het zou kunnen zijn. Je kunt proberen je USW op STP te zetten, dat is het spanning tree protocol dat Sonos nodig heeft als ie door je switches heen moet en ik kan me zo maar voorstellen dat dat bij jou zo is ivm mixed mode. Probleem speelt ook weer niet als je alles op SonosNet hebt.

 

 

En….altijd zorgen dat je een backup hebt van je controller waar je zo aan kunt voordat je settings gaat aanpassen.

Badge

Roam zit niet op het gasten netwerk. VLAN heb ik niet in gebruik. Firewall regels zal ik naar kijken (niet veel verstand van), maar tot nu toe nooit problemen mee gehad. Zou ook niet oorzaak kunnen zijn lijkt me want op een gegeven moment is de Roam toch zichtbaar.Spanning Tree Protocol staat idd op RSTP. Zal dit op een later tijdstip aanpassen. Zal na examenweken worden want anders slaan de pubers id stress mocht het netwerk niet meer werken. 

Reputatie 6
Badge +3

Roam zit niet op het gasten netwerk. VLAN heb ik niet in gebruik. Firewall regels zal ik naar kijken (niet veel verstand van), maar tot nu toe nooit problemen mee gehad. Zou ook niet oorzaak kunnen zijn lijkt me want op een gegeven moment is de Roam toch zichtbaar.Spanning Tree Protocol staat idd op RSTP. Zal dit op een later tijdstip aanpassen. Zal na examenweken worden want anders slaan de pubers id stress mocht het netwerk niet meer werken. 

Als je RSTP gaat aanpassen naar STP, gaat je netwerk er een paar minuten uit. Dat doe je het best op een geschikt tijdstip en zorg dat je een backup paraat hebt, dat moet altijd trouwens. Mijn best guess over je probleem zit trouwens wel in die hoek. Het zou kunnen dat RSTP de poort tijdelijk blokkeert, heb ik ook gehad en dan neemt SonosNet het over maar de Roam kan dat niet. Het moet voor elke switch trouwens als je er meerdere hebt.

Rest, dus VLAN, Guest, Firewall kun je vergeten, dat is het dan niet.

Reputatie 6
Badge +3

Er is trouwens een manier om te controleren of een poort genegeerd wordt in je switch, de poort laat dan in het status vakje het onderstaande stop-teken zien van RSTP discarding. Je kunt eens controleren of je dat (soms & tijdelijk) ziet in 1 v/d poorten waar bij jou een AP aan hangt.

 

 

Badge

Dank je dan zou er dus door het vakje bij Status dat rondje met streepje moeten komen te staan? het ziet er bij mij bijna net als bij jou uit

 

Reputatie 6
Badge +3

Klopt, het kwam bij me op dat RSTP de poort zou kunnen blokkeren waar de UAP aan gekoppeld is die het wifi naar de Roam verzorgd. Dan komt er zo`n rondje met streepje in het status symbool; ik heb dat gehad met meerdere Sonos speakers die bekabeld waren aan mijn switches. Door de switches dan te downgraden naar STP (verouderd protocol) werd het weer opgelost want dat is hetzelfde protocol dat Sonos gebruikt, dus dan praat het weer met elkaar.  Beide, dus RSTP en STP zijn bedoeld om een ‘loop free’ netwerk te krijgen. Ook in een netwerk zijn er meerdere wegen die naar Rome leiden, (R)STP zorgt er voor dat altijd de meest efficiënte weg gekozen wordt en de andere wegen afgesloten worden zodat er geen verkeersinfarct op je netwerk ontstaat. Rapid STP is simpelweg de opvolger van STP maar Sonos kan er niet mee overweg, dus gaat die je netwerk bombarderen waardoor RSTP van je switch weer ingrijpt door die poort te negeren en dan zie je dat symbool. Ik dacht dat dat misschien bij jou ook aan de hand is. Op dat moment wordt de Roam immers onzichtbaar in je netwerk.

 

Ik ben zelf inmiddels weer naar RSTP, heb de poorten van mijn bekabelde Sonos `en uitgezet en een Boost als enige bekabeld aan mijn Switch. Heb jij allemaal niks aan want die Roam moet op wifi. 

 

Kan niet anders dan dat Sonos meer gebruikers tegenkomt die problemen hebben met de mixed mode, zeker in combinatie met managed switches die moderner zijn dan Sonos zelf is.

Badge

thx. voor je uitgebreide antwoorden. Helemaal top. Zo kom ik ook meer te leren over netwerk en instellingen. Als het zo aanmodderen blijft dan gaat de Roam retour. Ik heb hem juist gekocht ter vervanging van een Bluetooth speaker voor de WiFi functionaliteit en bediening vanuit app.

Reputatie 6
Badge +3

Ja, weet je, ik ben gewoon bang dat je netwerk te goed is om Sonos op deze manier aan te kunnen, dus in mixed mode. Dat klinkt vreemd maar dat ligt echt aan Sonos en de soms verouderde standaarden die ze nog hanteren. Zoek maar eens op RSTP op de internationale Sonos forums, er zijn veel mensen die daarom vragen. 

Zelf zou ik in jouw geval de test aangaan om te kijken of het met STP wel werkt, gewoon om te kijken of dat het is. Bij mij werkte het toen feilloos maar ik weiger om mijn gehele netwerk, dat vergelijkbaar is met dat van jou, op die STP standaard te zetten. Dat voelt gewoon als terug in de tijd, zeg maar Windows XP vs Windows 10, zo moet je het zien.

Mocht dat het probleem oplossen, dan kun je de keuze maken zoals je in je vorige post al aangeeft. Als het dat niet is, moeten we verder speuren, het moet ergens aan liggen.

Ik lees ook wel meer dat die mixed mode een deal breaker is voor mensen om een Roam te kopen, inclusief mezelf. 

Reputatie 6
Badge +3

Ow, en...graag gedaan trouwens, ik geef niet altijd zulke uitgebreide antwoorden hoor :joy: . Alleen maar als het Sonos met zo`n state of the art Unifi netwerk is, dan kom ik los haha. Je hebt top netwerkapparatuur in huis, vind ik leuk.